Вопрос по информатике:
Задачи по Паскалю.Условный оператор.
1.Даны два действительных числа меньшее из них замените полусуммой их, а большее их произведением.
2.Найдите решение уравнения ах+ в=0, если оно существует,если а=0
3.написать программу удвоения меньшего из двух чисел
- 18.05.2016 12:29
- Информатика
- remove_red_eye 18248
- thumb_up 48
Ответы и объяснения 1
1)
program chik2;
var a,b,c:real;
begin
readln(a,b);
if(ac:=a;
a:=(a+b)/2;
b:=b*c;
end;
if(a>=b)then begin
c:=b;
b:=(a+b)/2;
a:=a*c;
end;
writeln(a,' ',b);
end.
2)
program chik;
var a,x,b:real;
begin
readln(a,b);
if(a=0)and(b0)then writeln('НЕТ решений');
if(a0)then begin
x:=-b/a;
writeln(x);
end;
end.
3)
program chik3;
var a,b:real;
begin
readln(a,b);
if(aif(bwriteln(a,' ',b);
end.
- 19.05.2016 00:53
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.