Вопрос по информатике:
Написать программу, которая добавляет пробелы в строку.(То есть: Если в тексте есть знак препинания «.», «,», «!» или «?», и после отсутствует пробел)
- 11.03.2015 21:19
- Информатика
- remove_red_eye 6652
- thumb_up 16
Ответы и объяснения 1
Var
s1,s2:string;
i,k:integer;
begin
readln(s1);
k:=length(s1)-1;
s2:='';
for i:=1 to k do
begin
s2:=s2+s1[i];
case s1[i] of
'.',',','!','?':
if s1[i+1]' ' then s2:=s2+' ';
end;
end;
s2:=s2+s1[k+1];
writeln(s2)
end.
- 12.03.2015 06:15
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.