Вопрос по информатике:
Написать программу в паскале:1.Дано целое число. Вычислить, если возможно, натуральный логарифм этого числа и вывести его на экран. В противном случае вывести сообщение об ошибке.
- 02.02.2015 02:22
- Информатика
- remove_red_eye 16711
- thumb_up 37
Ответы и объяснения 1
Логарифм существует только для положительных чисел.
Поэтому напишем такую программу:
var x:integer;
BEGIN
writeln('Введите число');
readln(x);
if x<=0 then
writeln('Логарифм этого числа не существует')
else write('ln=',ln(x))
END.
- 03.02.2015 15:41
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.