Вопрос по информатике:
Напишите программу(Паскаль), которая считывает с клавиатуры последовательность символов и выводит на экран количество нечетных цифр :с
- 24.02.2018 21:50
- Информатика
- remove_red_eye 6393
- thumb_up 18
Ответы и объяснения 1
Var
n, k, a, i: integer;
begin
write('Введите кол-во чисел: ');
readln(n);
for i:=1 to n do
begin
read(a);
if ((a mod 2) = 1) then inc(k);
end;
write(k);
end.
С использованием оператора repeat:
var
n, k, a, i: integer;
begin
write('Введите кол-во чисел: ');
readln(n);
repeat
read(a);
if ((a mod 2) = 1) then inc(k);
inc(i);
until i=n;
write(k);
end.
n - кол-во чисел, k - кол-во нечётных чисел, a - число
Все числа вводятся через пробел
- 25.02.2018 16:48
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.