Вопрос по информатике:
Напишите программу которая получает два целых числа и находит их произведение не используя операцию умножения. учтите что числа могут быть отрицательными.На Turbo Pascal пожалуйста срочно!!!!!Зарвнее спасибо!
- 04.04.2017 08:18
- Информатика
- remove_red_eye 13885
- thumb_up 39
Ответы и объяснения 1
Вот. Умножение без помощи операции умножения. Делай лучшим) program pr; var i,a,b:integer;p:real; begin write('Первый множитель: '); readln(a); write('Второй множитель: '); readln(b); if b<0 then begin b:=-b; for i:=1 to b do begin p:=p+a; end; writeln(-p:0:2); end else begin for i:=1 to b do p:=p+a; writeln(p:0:2) end; end.
- 05.04.2017 23:06
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.