Вопрос по информатике:
1.Вводится номер месяца. Надо определить к какому сезону относится этот месяц
2.Написать программу, которая грамотно печатает фразу "У меня К друзей". К вводится с клавиатуры. Например, для К=1 должно напечататься " У меня 1 друг", для К=24 - "У меня 24 друга", для К=100 - "У меня 100 друзей".
Решить в паскаль абс
- 15.12.2016 18:27
- Информатика
- remove_red_eye 17830
- thumb_up 30
Ответы и объяснения 1
1:
program a1;
var i:integer;
begin
readln(i);
if i>2 then if i>5 then if i>8 then if i>11 then writeln('Зима') else writeln('Осень') else writeln('Лето') else writeln('Весна') else writeln('Зима');
end.
2:
program a2;
var k:integer;
begin
readln(k);
if k mod 10 = 1 then
writeln('У меня ',k,' друг') else
begin
if (k mod 10 1)and(k div 10 1) then
writeln('У меня ',k,' друга')
else
writeln('У меня ',k,' друзей');
end;
end.
//Вроде все продумал если нет, извиняйте
- 16.12.2016 14:23
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.