Вопрос по информатике:
1.Вводится номер месяца. Надо определить к какому сезону относится этот месяц
2.Написать программу, которая грамотно печатает фразу "У меня К друзей". К вводится с клавиатуры. Например, для К=1 должно напечататься " У меня 1 друг", для К=24 - "У меня 24 друга", для К=100 - "У меня 100 друзей".
Написать программу в PascalABC
- 13.05.2015 12:00
- Информатика
- remove_red_eye 2545
- thumb_up 17
Ответы и объяснения 1
1)
var x:integer;
begin
read (x);
if (x=12) or (x=1) or (x=2) then writeln ('Зима');
if (x=3) or (x=4) or (x=5) then writeln ('Весна');
if (x=6) or (x=7) or (x=8) then writeln ('Лето');
if (x=9) or (x=10) or (x=11) then writeln ('Осень');
end.
2)
var K,a:integer;
begin
readln(K);
a:=K mod 10;
if (K=11) or(K=12) or (K=13) or (K=14) then writeln ('У меня ',K,' друзей') else
begin
if (a=1) then writeln ('У меня ',K,' друг');
if (a=0) or ((a>=5) and (a<=9)) then writeln ('У меня ',K,' друзей');
if (a>=2) and (a<=4) then writeln ('У меня ',K,' друга');
end;
end.
- 14.05.2015 18:33
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.