Вопрос по информатике:
Написать программу,которая находит все четырехзначные числа abcd,для которых выполняются условия
1)a,b,c,d-разные цифры
2)a*b-c*d=a+b+c+d
- 20.02.2016 21:19
- Информатика
- remove_red_eye 10083
- thumb_up 34
Ответы и объяснения 1
Program fofgogjoj;
var
a,b,c,d:integer;
begin
for c:=0 to 7 do
begin
a:=c+2;
d:=9-c;
for b:=0 to 9 do
begin
if (bc)and(ba)and(bd) then
Writeln(a,b,c,d);
Writeln;
end;
end;
readln;
end.
- 21.02.2016 00:30
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.