Вопрос по информатике:
Дан целочисленный массив из 10 элементов.Элементы массива могут принимать целые значения от -50 до 50.Составить программу ,позволяющую найти и вывести сумму элементов массива которые кратны 7 и оканчиваются на 5 .Гарантируется,что в исходном массиве есть хотя бы один такой элемент.
НА ЯЗЫКЕ ПАСКАЛЬ!!!!
- 16.03.2018 20:22
- Информатика
- remove_red_eye 10561
- thumb_up 33
Ответы и объяснения 1
Const N=10;
TYPE Chisla = array [1..N] of integer;
var f: Chisla;
procedure IChisla (N: integer; var a: Chisla);
begin for var i := 1 to N do a[i] := random(-50, 50);
end;
procedure OChisla(N: integer;a: Chisla);
begin
for var i := 1 to N do write(a[i]:5);
end;
function Sum (a:Chisla): integer;
begin
for var i:=1 to N do
if (a[i] mod 7 = 0) and (a[i] mod 10 = 5) then result:= result+f[i];
end;
BeginI
Chisla (N, f);
OChisla (N, f);
writeln ('Вывести сумму', Sum(f));
End.
- 17.03.2018 04:10
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.