Вопрос по информатике:
Напишите программу для решения следующей задачи.Девятиклассники участвовали в викторине по математике. Необходимо было ответить на 20 вопросов. Победителем викторины считается участник, правильно ответивший на наибольшее количество вопросов. На сколько вопросов победитель ответил правильно? Если есть участники викторины, которые не смогли дать правильный ответ ни на один из вопросов, выведите YES, иначе выведите NO. Гарантируется, что есть участники, правильно ответившие хотя бы на один из вопросов.Программа получает на вход число участников викторины N (1 ≤ N ≤ 50), затем для каждого участника вводится количество вопросов, на которые получен правильный ответ.
Пример работы программы:Входные данные 4 15 12 0 17
Выходные данные 17 YES
- 14.09.2017 05:04
- Информатика
- remove_red_eye 10094
- thumb_up 21
Ответы и объяснения 1
Var
i, k,n, max: integer;
f:boolean;
begin
readln(k);
for i := 1 to k do
begin
readln(n);
if (i = 1) or (max < n) then
max := n;
f:=f or (n=0);
end;
writeln(max,' ', f);
end.
- 15.09.2017 04:39
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.