Вопрос по информатике:
СРОЧНО! Составить АЛГОРИТМ иСРОЧНО! Составить АЛГОРИТМ и БЛОК-СХЕМУ(!) к каждой задаче. Кто хорошо разбирается, помогите пожалуйста!
1. Даны действительные числа х,у. меньшее из этих двух чисел заменить их полусуммой, а большее их удвоенным произведением.
2. Даны х,у. если х,у отрицательны, то каждое значение заменить его модулем;если отрицательно только одно из них, то оба значения увеличить на 0,5; если оба знач. неотрицательны, то оба знач. увеличить в 10 раз
3. Даны три числа а, b, с. выяснить верно ли, что а,<b<c. ответ получить в текстовой форме: верно или нет
4. Написать программу выбора наибольшего из трех чисел
5. Даны три действительных числа . возвести в квадрат те из них, значения которых неотрицательны.
- 14.07.2018 04:46
- Информатика
- remove_red_eye 2334
- thumb_up 17
Ответы и объяснения 1
Ответ на 1 задачу
Алгоритм выглядит таким образом:
ввести x, y;
если x>y то
s:=(x*y)*2;
иначе
s:=(x+y)/2;
вывод s
конец. (блок-схема прилагается в скриншоте 1)
На паскале выглядит примерно так:
var
x, y, s:real;
begin
readln(x,y);
if x>y then
s:=(x*y)*2;
else
s:=(x+y)/2;
writeln(s:2:2);
end.
Ответ на 2 задачу
Тут идентичный алгоритм: вводим 2 переменные x, y, далее создаем условие и возводим в модуль... (скриншот 2 с блок-схемой)
Ответ на 3 задачу
Тут тоже.. в условии указываешь просто a
На паскале выглядит примерно так:
var
a, b, c:integer; {если число вещественное}
begin
readln(a, b, c);
if (awriteln("Верно");
else
writeln("Неверно");
end.
Ответ на 4 задачу
На паскале:
var
a, b, c, max:integer;
begin
max:=0;
readln(a,b,c);
if maxmax:=a;
if maxmax:=b;
if max
writeln(max);
end.
Ответ на 5 вопрос
На паскале:
Var
a,b,c:integer;
begin
readln(a,b,c);
if (a<0) then
a:=a*a;
writeln(a);
if (b<0) then
b:=b*b;
writeln(b);
if (c<0) then
c:=c*c;
writeln(c);
end.
Удачи!
- 15.07.2018 23:01
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.