Вопрос по информатике:
Составить программу и блок схему вывода всех чисел от 1000 до 9999, в которых 1 цифра равна 4 и 2 цифра равна 3.
- 01.02.2018 00:12
- Информатика
- remove_red_eye 12972
- thumb_up 15
Ответы и объяснения 1
Почему-то мой ответ удалили. Напишу подробнее.
Если в чмсле первая цифра 4 и вторая цифра 3, то числа от 4300 до 4399
На паскле программа выглядит так
var i, n: integer
begin
uses crt;
for i:= 0 to 99
begin
n = 4300 + i;
write (n);
end;
writeln;
end.
Блок-схема совсем простая, нарисуй сама.
1) Начало (в овале)
2) i = 0 (в прямоугольнике)
3) n = 4300 + i (в прямоугольнике)
4) Вывод n (в параллелограмме)
5) Проверка i > 99 ? (в ромбе). Если нет, возврат на п. 3. Если да, вниз.
6) Вывод пустой строки (в параллелограмме)
7) Конец (в овале)
- 02.02.2018 08:14
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.