Вопрос по информатике:
Каждый ежедневно болеющий гриппом человек может заразить окружающих. Составьте программу, определяющую, через сколько дней заболеют все ученики школы. Число учащихся школы ввести с клавиатуры.
- 26.06.2018 10:52
- Информатика
- remove_red_eye 13623
- thumb_up 18
Ответы и объяснения 1
При условии что каждый больной заражает от 1 до 5 человек каждый день, и что больные упорно ходят в школу
const
min_posible = 1;
max_posible = 5;
var all_students, ill, new_ill, days, i: integer;
Begin
Randomize;
Writeln('Кол-во учеников школы =>');
read(all_students);
ill := 1;
repeat
days := days + 1;
new_ill := 0;
for i := 1 to ill do
new_ill := new_ill + Random(min_posible, max_posible);
ill := ill + new_ill;
Writeln('День ',days:3,': Заразилось ',new_ill:5,' Больных ',ill:5);
until ill >= all_students;
Writeln(days);
End.
- 27.06.2018 04:10
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.