Вопрос по информатике:
написать программу:по заданному порядковому номеру дня недели напечатать его название и указать рабочий это день или не рабочий
- 14.05.2016 13:30
- Информатика
- remove_red_eye 10338
- thumb_up 13
Ответы и объяснения 2
Var month:integer;
begin
readln(month);
if ((month >0 ) and ( month < 13)) then
case month of
1 : writeln ('january (31 days) ');
2 : writeln ('fabruary (28 days) ');
3 : writeln ('march (31 days)');
4 : writeln ('April (31 days) ');
5 : writeln ('fabruary (28 days)');
6 : writeln ('march (31 days)');
7 : writeln ('january (31 days) ');
8 : writeln ('fabruary (28 days) ');
9 : writeln ('march (31 days)');
10 : writeln ('january (31 days) ');
11 : writeln ('fabruary (28 days) ');
12: writeln ('march (31 days)');
end
else writeln('error');
readln;
end.
- 15.05.2016 10:08
- thumb_up 46
var
a: array [1..7] of System.Tuple;
i: byte;
begin
a[1] := new System.Tuple(true, 'Понедельник');
a[2] := new System.Tuple(true, 'Вторник');
a[3] := new System.Tuple(true, 'Среда');
a[4] := new System.Tuple(true, 'Четверг');
a[5] := new System.Tuple(true, 'Пятница');
a[6] := new System.Tuple(false, 'Суббота');
a[7] := new System.Tuple(false, 'Воскресение');
readln(i);
writeln((i in [1..7] ? String.Format('Day #{0} is {1}. It is {2}.', i, a[i].Item2,
(a[i].Item1 ? 'working day' : 'weekend')) : 'There aren`t this day.'));
end.
- 16.05.2016 16:42
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.