Вопрос по информатике:
Сорочно !!!!!!!!Напишите программу которая в последовательности целых чисел определяет кол-во кратных 5 или 7 . программа получает на вход целые числ кол-во введеных чисел неизвестно последовальность чисел заканчивается число 0 ( 0 признак окончания ввода не входит в последовательность) ко-во чисел не превышает 1000 введеные числа по модулу не превышает 30 000 программа должна вывести оно число кол-во чисел кратных 5 или 7 пример работы
- 22
25
-14
0
выходные данные
2
- 02.07.2018 14:27
- Информатика
- remove_red_eye 7431
- thumb_up 19
Ответы и объяснения 1
Using System;
namespace ConsoleApp {
internal class Program {
private static void Main() {
var number = 0;
int n;
do {
Console.WriteLine("Введите число");
n = Convert.ToInt32(Console.ReadLine());
if (n != 0 && (n % 5 == 0 || n % 7 == 0)) {
number++;
}
} while (n != 0);
Console.WriteLine("Кол-во = " + number);
Console.ReadKey();
}
}
}
- 03.07.2018 11:53
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.