Вопрос по информатике:
Даны три натуральных числа. напишите программу в паскале , определяющую , существует ли треугольник с такими длинами сторон. Если такой существует , то определите его тип (равносторонний , равнобедренный, разносторонний) СРОЧНО! ЗАРАНЕЕ СПАСИБО.
- 11.07.2018 23:33
- Информатика
- remove_red_eye 8463
- thumb_up 38
Ответы и объяснения 1
Var
a,b,c,k:integer;
begin
readln(a,b,c);
if (a+b>c)and(b+c>a)and(a+c>b) then begin
writeln('треугольник существует');
k:=1
end
else writeln('треугольник не существует');
if (a=b)and(a=c) and (k=1) then
writeln('равносторонний');
if (((a=b)and(ac))or((c=b)and(ca))or((c=a)and(cb)))and (k=1) then
writeln('равнобедренный');
if (ab)and(cb)and(ac)and (k=1) then
writeln('разносторонний')
end.
- 12.07.2018 14:07
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.