Вопрос по информатике:
дана последовательность целых чисел, заканчивающаяся нулем. написать программу, котороая подсчитывает количество чисел в последовательности
- 23.10.2017 11:29
- Информатика
- remove_red_eye 7684
- thumb_up 16
Ответы и объяснения 1
На паскале
program m1;
var a: aarray [1..10] of integer;
i,n,k: integer;
begin
readln (n);
for i:= 1 to n do readln (a[i]);
k:= 0;
for i:= 1 to n do begin
if a[i]0 then k:= k+1;
end;
writeln (k) {если 0 нужно учитывать в количестве то...} writeln (k+1);
end.
- 24.10.2017 21:57
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.