Вопрос по информатике:
Написать программу, которая в последовательности натуральных чисел определяет сумму всех чисел кратных 6 и оканчивающихся на 2. Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0( это признак окончания ввода, не входит в последовательность). Кол-во чисел не превышает 100. Введенные числа не превышают 300. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 2.
- 22.10.2017 07:18
- Информатика
- remove_red_eye 10398
- thumb_up 39
Ответы и объяснения 1
Var
sum, x : integer;
begin
sum := 0;
repeat
read (x);
if (x mod 6 = 0) and (x mod 10 = 2) then sum := sum + x;
until x = 0;
write (sum);
end.
- 24.10.2017 00:19
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.