Вопрос по информатике:
Даны 2 двузначных целых числа X и y.Найти D=MAX{x+y;y-x}+3,E=MIN{x^2+y^2;y^2+x*y}-4.если D<E,то к переменной D прибавить первую цифру числа E,иначе из числа взять корень степени,равной второй цифре числа.
Помогите,пожалуйста,написать программу в паскале ABC
- 26.03.2018 19:05
- Информатика
- remove_red_eye 18562
- thumb_up 35
Ответы и объяснения 1
Var x,y,k,err:integer;s:string;d,e:real;
begin
err:=0;
read (x,y);
d:=max (x+y,y-x) + 3;
e:=min (sqr(x)+sqr(y),sqr(y)+x*y) - 4;
str (e,s);
k:=length(s);
val (s,e,err);
if (d
d:=d+(e div (10*(k-1)));
end else
begin
d:=power (d,1/(e div (10*(k-2))));
end;
writeln (d);
end.
- 27.03.2018 22:48
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.