Вопрос по информатике:
"составьте программу вычисления суммы элементов от первого отрицательного и до конца"
pascal abc.
- 09.11.2017 22:32
- Информатика
- remove_red_eye 1563
- thumb_up 42
Ответы и объяснения 1
Var
mas:array[1..100] of integer;
i,n,sum:integer;
bool:boolean;
begin
bool:=false;
sum:=0;
readln(n);
for i:=1 to n do
begin
read(mas[i]);
if mas[i]<0 then
bool:=true;
if bool=true then
sum:=sum+mas[i];
end;
writeln(sum);
end.
- 01.01.1970 00:00
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.