Вопрос по информатике:
ПОЖАЛУЙСТА ПОМОГИТЕ ОЧЕНЬ НАДО
Написать программу, которая "задумывает" число в диапазоне от 1 до 10 и предлагает пользователю угадать число за 5 попыток.
- 03.08.2017 03:55
- Информатика
- remove_red_eye 14429
- thumb_up 8
Ответы и объяснения 1
(С подсказками, не надо - удали)
var r,ch,z: integer;
begin
Randomize;
r:=random(10)+1;
z:=5;
repeat
write('Отгадайте число от 1 до 10. У вас ',z,' попыток :');
readln(ch);
z:=z-1;
if z>0 then
begin
If ch
else writeln('Вы угадали!');
end
else Writeln('Попытки кончились!');
until (z=0)or(ch=r);
End.
- 04.08.2017 06:04
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.