Вопрос по информатике:
Напишите программу,которая вычисляет сумму:
а)первых n натуральных чисел;
б)квадратов первых n натуральных чисел
- 20.12.2017 06:32
- Информатика
- remove_red_eye 13510
- thumb_up 11
Ответы и объяснения 1
Решение на паскале:
а)
var sum,i,n: int64;
BEGIN
writeln('Введите N');
readln(n);
for i := 1 to n do
sum := sum + i; // можно написать так inc(sum, i);
writeln('Сумма первых ', n, ' натуральных чисел = ', sum);
END.
б)
var sum,i,n: int64;
BEGIN
writeln('Введите N');
readln(n);
for i := 1 to n do
sum := sum + sqr(i);
writeln('Сумма квадратов первых ', n, ' натуральных чисел = ', sum);
END.
- 21.12.2017 12:56
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.