Вопрос по информатике:
Напишите программу которая Определяет nod трех натуральных чисел (с использованием процедур) Срочно
- 16.06.2018 15:45
- Информатика
- remove_red_eye 5072
- thumb_up 24
Ответы и объяснения 1
Var
a,b,c:integer;
procedure main(a,b,c:integer);
var
i,max,nod:integer;
begin
if (a>b) and (a>c) then
max:=a
else
if (b>a) and (b>c) then
max:=b
else
max:=c;
nod:=1;
for i:=1 to max do
begin
if (a mod i = 0) and (b mod i = 0) and (c mod i = 0) then
nod:=i;
end;
writeln(nod);
end;
begin
read(a,b,c);
main(a,b,c);
end.
- 17.06.2018 02:26
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.