Вопрос по информатике:
Напишите программу,которая получает день,номер месяца и выводит кол-во дней,оставшихся до нового года)))Помогите пожалуйста!!!!!
- 13.07.2018 09:35
- Информатика
- remove_red_eye 1655
- thumb_up 31
Ответы и объяснения 1
Var
d,m,i,all:integer;
begin
read(d,m);
all:=0;
for i:=12 downto (m+1) do
begin
if i=12 then
all:=all+31;
if i=11 then
all:=all+30;
if i=10 then
all:=all+31;
if i=9 then
all:=all+30;
if i=8 then
all:=all+31;
if i=7 then
all:=all+31;
if i=6 then
all:=all+30;
if i=5 then
all:=all+31;
if i=4 then
all:=all+30;
if i=3 then
all:=all+31;
if i=2 then
all:=all+28;
if i=1 then
all:=all+31;
end;
if i=12 then
all:=all+31-d;
if i=11 then
all:=all+30-d;
if i=10 then
all:=all+31-d;
if i=9 then
all:=all+30-d;
if i=8 then
all:=all+31-d;
if i=7 then
all:=all+31-d;
if i=6 then
all:=all+30-d;
if i=5 then
all:=all+31-d;
if i=4 then
all:=all+30-d;
if i=3 then
all:=all+31-d;
if i=2 then
all:=all+28-d;
if i=1 then
all:=all+31-d;
writeln(all);
end.
- 14.07.2018 22:26
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.