Вопрос по информатике:
Помогите пожалуйста!!!!
Напишите программу на языке Паскаль через цикл repeat, которая вычисляет сумму:
а)первых n натуральных чисел
б)квадратов первых n натуральных чисел
в)всех чётных чисел в диапазоне от 1 до n
г)всех двузначных чисел
- 14.05.2018 17:32
- Информатика
- remove_red_eye 14214
- thumb_up 14
Ответы и объяснения 1
Program A_1;
uses crt;
Var
i,n,sum: integer;
begin
write('Введите N ');
readln(n);
i:=0;
sum:=0;
repeat
i:=i+1;
sum:=sum+i;
until i=n;
writeln('Сумма чисел от 1 до ',n,' равна ',sum);
end.
Program B_2;
uses crt;
Var
i,n,sum: integer;
begin
write('Введите N ');
readln(n);
i:=0;
sum:=0;
repeat
i:=i+1;
sum:=sum+i*i;
until i=n;
writeln('Сумма квадратов чисел от 1 до ',n,' равна ',sum);
end.
Program V_3;
uses crt;
Var
i,n,sum: integer;
begin
write('Введите N ');
readln(n);
i:=0;
sum:=0;
repeat
i:=i+1;
if (i mod 2 = 0) then sum:=sum+i;
until i=n;
writeln('Сумма чётных чисел в диапазоне от 1 до ',n,' равна ',sum);
end.
Program G_4;
uses crt;
Var
i,n,sum: integer;
begin
i:=9;
sum:=0;
repeat
i:=i+1;
sum:=sum+i;
until i=99;
writeln('Сумма всех двузначных чисел равна ',sum);
end.
- 15.05.2018 06:45
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.