Вопрос по информатике:
Написать программу приведения дробей к наименьшему общему знаменателю. Пользователь вводит две дроби. Программа приводит дроби к наименьшему общему знаменателю. СРОЧНО
- 05.12.2017 00:13
- Информатика
- remove_red_eye 5430
- thumb_up 14
Ответы и объяснения 1
Нахождение НОК двух чисел, оформите под вашу задачу
var
x, y: integer;
function NOD(x, y: integer): integer;
begin
if x0 then NOD:=NOD(y mod x, x)
else NOD:=y;
end;
function NOK(x, y: integer): integer;
begin
NOK:=(x div NOD(x,y))*y;
end;
begin
read(x, y);
write(NOK(x, y));
end.
- 05.12.2017 16:34
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.