Вопрос по информатике:
Составьте программу для нахождения среднего арифметического двухзначных чисел кратных 3
- 25.03.2016 18:25
- Информатика
- remove_red_eye 706
- thumb_up 50
Ответы и объяснения 1
Допустим дана последовательность числе из n элементов
Pascal
var
mas:array[1..100] of integer;
n2,sum,i,n:intger;
begin
readln(n);
sum:=0;
n2:=0;
for i:=1 to n do
read(mas[i]);
for i:=1 to n do
begin
if (mas[i] mod 3 = 0) and (mas[i]>9) and (mas[i]<100) then
begin
n2:=n2+1;
sum:=sum+mas[i];
end;
end;
writeln(sum/n2);
end.
- 26.03.2016 18:16
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.