Вопрос по информатике:
20.2 Напишите программу, которая в последовательности натуральных
чисел находит среднее арифметическое чисел, кратных 4, или
сообщает, что таких чисел нет (выводит NO). Программа получает на
вход натуральные числа, количество введённых чисел неизвестно,
последовательность чисел заканчивается числом 0 (0 - признак окончания
ввода, не входит в последовательность).
Количество чисел не превышает 100. Введённые числа не превышают 300.
Программа должна вывести среднее арифметическое чисел, кратных 4, или
вывести «NO», если таких чисел нет.
Заранее спасибо.
- 08.09.2018 11:54
- Информатика
- remove_red_eye 14990
- thumb_up 30
Ответы и объяснения 1
Var x, y, count, s: integer;
begin
repeat
if(y = 100) then break;
readln(x);
if(abs(x) > 300) then begin
writeln('Число по модулю не может быть > 300.');
continue
end
else
if(x mod 4 = 0) and (x 0) then begin
inc(count);
s := s + x;
end;if(x 0) then inc(y);
until(x = 0);
writeln('Среднее арифметическое: ', s / count);
end.
- 09.09.2018 16:13
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.