Вопрос по информатике:
Паскаль АВС! Составить программу,определяющую какая буква слова S(первая или последняя) чаще в нем встречается.
- 07.08.2018 14:46
- Информатика
- remove_red_eye 5291
- thumb_up 49
Ответы и объяснения 1
VAR
s: String;
s1,s2,i: LongInt;
BEGIN
Read(s);
s1 := 0; s2 := 0;
for i := 1 to Length(s) do begin
if (s[i] = s[1]) then Inc(s1);
if (s[i] = s[Length(s)]) then Inc(s2);
end;
if (s1 > s2) then Write('Первая буква');
if (s1 < s2) then Write('Последняя буква');
if (s1 = s2) then Write('Равное количество раз.');
END.
- 08.08.2018 04:26
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.