Вопрос по информатике:
Составьте программу, определяющую, является ли данное натуральное число простым.
Это Паскаль.
- 23.07.2018 14:13
- Информатика
- remove_red_eye 19390
- thumb_up 12
Ответы и объяснения 1
Uses crt;
var x,i,flag:integer;
begin
clrscr;
writeln("x=");
read(x);
for i:= 1 to x
begin
if (x div i )0 then
flag:=flag+1;
end;
if (flag = 2)
write("chislo prostoe")
else
write("chislo ne prostoe");
readln;
end.
- 24.07.2018 17:20
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.