Вопрос по информатике:
Нужно составить программу, вычисляющую сумму только положительных чисел из трех вводимых с клавиатуры. в Турбо Паскале
- 21.11.2017 04:26
- Информатика
- remove_red_eye 18461
- thumb_up 27
Ответы и объяснения 2
Program picaso; uses crt;
var a,b,c,s:integer;
begin clrscr;
writeln('A:');read(a);
writeln('B:');read(b);
writeln('C:');read(c);
if(a > 0) then a:=a else a:=0;
if(b > 0) then b:=b else b:=0;
if(c > 0) then c:=c else c:=0;
s:=a+b+c;
writeln(s);
readln;
end.
- 22.11.2017 05:05
- thumb_up 38
Var a,b,c,ap,bp,cp:real;
begin
read(a,b,c);
if a>0 then ap:=a else ap:=0;
if b>0 then bp:=b else bp:=0;
if c>0 then cp:=c else cp:=0;
write (ap+bp+cp);
end.
- 23.11.2017 02:06
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.