Вопрос по информатике:
УМОЛЯЮ,ПОМОГИТЕ С ПАСКАЛЕМ
1)
Вычислить оптимальный вес по формуле рост-100 (фактический вес V и рост H вводятся пользователем) и выдать одно из сообщений:
- у вас идеальный вес;
- вам нужно похудеть на n кг (n вывести);
- вам нужно поправиться на n кг (n вывести).
2)Составить программу, которая бы по последней цифре многозначного числа выдавала бы одно из сообщений:
число не делится ни на 2, ни на 5
число делится только на 2
число делится только на 5
число делится и на 2, и на 5.
- 21.01.2018 23:05
- Информатика
- remove_red_eye 3522
- thumb_up 24
Ответы и объяснения 1
1)
var v,h,i:real;
begin
readln(v);
readln(h);
i:=h-100;
if v=i then writeln('у вас идеальный вес') else
if v>i then writeln('вам нужно похудеть на ', v-i,' кг ') else
writeln('вам нужно поправиться на ', i-v,' кг ');
end.
2)
var a:string;
b:integer;
begin
readln(a);
b:=strtoint(a[length(a)]);
if (b mod 2 0) and (b mod 5 0) then writeln('число не делится ни на 2, ни на 5');
if (b mod 2 = 0) and (b mod 5 0) then writeln('число делится только на 2');
if (b mod 2 0) and (b mod 5 = 0) then writeln('число делится только на 5');
if (b mod 2 = 0) and (b mod 5 = 0) then writeln('число делится и на 2, и на 52');
end.
- 22.01.2018 04:05
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.