Вопрос по информатике:
составить программу нахождения максимального элемента в массиве из 30 чисел
- 16.05.2018 09:19
- Информатика
- remove_red_eye 948
- thumb_up 33
Ответы и объяснения 1
Эта автоматически тебе всё сделает.
Var i, n, max : Integer;
a : array [1..30] of Integer;
begin
for i := 1 to 30 do
begin
Write('a[', i, ']=');
a[i]:=i+1;
if max writeln(a[i]);
end;
writeln('Максимальный элемент равен: ',max);
end.
Если нужно будет ввести последовательность с клавиатуры, то вот:
Var i, n, max : Integer;
a : array [1..30] of Integer;
begin
for i := 1 to 30 do
begin
Write('a[', i, ']=');
ReadLn (a[i]);
if maxend;
writeln('Максимальный элемент равен: ',max);
end.
- 17.05.2018 20:09
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.