Вопрос по информатике:
ПОМОГИТЕ С ПРОГРАММОЙ, ПОЖАЛУЙСТА!
нужно написать программу, которая по вводу с клавиатуры последовательности целых чисел (признак окончания ввода- ввод числа 0) подсчитывает среднее арифметическое НЕЧЕТНЫХ чисел и чисел, КРАТНЫХ 5.
- 13.09.2018 17:10
- Информатика
- remove_red_eye 17310
- thumb_up 46
Ответы и объяснения 2
Var
A,i:integer;
B:real;
Begin
repeat
Writeln('Введи число.');
ReadLn(A);
if (A mod 10 =0) then
Begin
i:=i+1;
B:=A+B;
End;
until (A=0);
WriteLn('Среднее арифметическое нечетных чисел кратных 5 равно: ',B/(i-1));
ReadLn
End.
- 14.09.2018 08:57
- thumb_up 45
Var x,i:integer;
y:real;
Begin
writeln('Признак окончания ввода - ввод числа 0');
repeat
Writeln('Введите число');
ReadLn(x);
if (x mod 2 >0) and (x mod 5 = 0) then
Begin i:=i+1;
y:=x+y;
End;
until (x=0);
WriteLn('Среднее арифметическое нечетных чисел кратных 5 = ',y/i);
End.
- 15.09.2018 03:50
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.