Вопрос по информатике:
1.Дан одномерный массив.Найти произведение элементов массива кратных 3,нужно в Pascale программу вот эту написать
2.Подсчитать средний балл за экзамен по математике у учащихся,сдавших его.Тоже через программу Паскаль написать программу.
Помогите плиз)))
- 07.12.2017 05:51
- Информатика
- remove_red_eye 7442
- thumb_up 20
Ответы и объяснения 1
1)
uses crt;
const size = 10;
var a:array [1..size] of integer;
i,p:longint;
begin
p:=1;
randomize;
for i:=1 to size do
begin
a[i]:=random(20);
write (a[i],' ');
if (a[i] mod 3 = 0) then p:=p*a[i];
end;
writeln;
writeln (p);
end.
2)
uses crt;
const size = 10;
var a:array [1..size] of integer;
i:integer;
s:real;
begin
s:=0;
randomize;
for i:=1 to size do
begin
a[i]:=random(4)+1;
write (a[i],' ');
s:=s+a[i];
end;
writeln;
s:=s/size;
writeln (s);
end.
- 08.12.2017 04:30
- thumb_up 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.