Вопрос по информатике:
Составить программу,определяющую какая буква слова x(первая или последняя) чаще встречается в слове y. Паскаль!!!
- 26.10.2017 02:58
- Информатика
- remove_red_eye 5757
- thumb_up 17
Ответы и объяснения 1
Var x,temp:string;
first,last:char;
k1,k2:integer;
begin
write ('X = ');
readln (x);
k1:=0;
k2:=0;
first:=x[1];
last:=x[length(x)];
temp:=x;
while (pos(first,temp)>0) do
begin
inc(k1);
delete (temp,pos(first,temp),1);
end;
temp:=x;
while (pos(last,temp)>0) do
begin
inc(k2);
delete (temp,pos(last,temp),1);
end;
if (k1>k2) then writeln ('First') else
if (k2>k1) then writeln ('Last') else
writeln ('Equal');
end.
- 27.10.2017 19:13
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.