Вопрос по информатике:
Составьте программу, определяющую номер координатной четверти, в которой находится точка с координатами(х,y). Если точка лежит на оси координат или в начале координат, то выведите соответствующее сообщение. Числа х,y вводятся с клавиатуры. желательно с объяснением.
- 23.08.2016 23:09
- Информатика
- remove_red_eye 7700
- thumb_up 16
Ответы и объяснения 1
Pascal:
var x,y:integer;
begin
readln (x,y);
if (x>0) and (y>0) then writeln ('Точка лежит в первой четверти');
if (x0) then writeln ('Точка лежит во второй четверти');
if (x<0) and (y<0) then writeln ('Точка лежит в третьей четверти');
if (x>0) and (y<0) then writeln ('Точка лежит в четвертой четверти');
if (x=0) and (y=0) then writeln ('Точка лежит на пересечении осей') else
if x=0 then writeln ('Точка лежит на оси ординат') else if y=0 then writeln ('Точка лежит на оси абсцисс');
readln;
end.
- 24.08.2016 22:41
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.