Вопрос по информатике:
Дана строка. Указать те слова, которые содержат хотя бы одну букву k. Составить программу на Паскаль. Заранее спасибо ^_^
- 14.10.2017 10:31
- Информатика
- remove_red_eye 13275
- thumb_up 8
Ответы и объяснения 1
Var s,tmp:string;
i,n:integer;
flag,word:boolean;
function letter (const let:char):boolean;
begin
if ((let>='a') and (let='A') and (let<='Z')) then letter:=true
else letter:=false;
end;
begin
readln (s);
s:=s+' ';
n:=length(s);
flag:=false;
for i:=1 to n do
begin
if (letter(s[i])) and (not flag) then
begin
flag:=true;
tmp:='';
word:=false;
end else if (not letter(s[i])) and (flag) then
begin
flag:=false;
if (word) and (not (tmp='')) then writeln (tmp);
end;
if (flag) then
begin
tmp:=tmp+s[i];
if (s[i]='k') then word:=true;
end;
end;
end.
- 15.10.2017 00:40
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.