Вопрос по информатике:
Известны координаты вершин A,B,C треугольника. Напишите программу, вычисляющую площадь этого треугольника
- 15.06.2018 09:05
- Информатика
- remove_red_eye 17497
- thumb_up 9
Ответы и объяснения 1
#include
#include
class point
{
int x;
int y;
public:
point(): x(0), y(0) {}
void setkoord(int koordx,int koordy)
{
x = koordx;
y = koordy;
}
int getx()const { return x; }
int gety()const { return y; }
};
double length(point p1, point p2)
{
return (sqrt(pow(double(p1.getx()-p2.getx()),2)+pow(double(p1.gety()-p2.gety()),2)));
}
int main()
{
point A,B,C;
B.setkoord(1,1);
C.setkoord(1,0);
double a=length(A,B), b=length(B,C), c=length(C,A);
double p=(a+b+c)/2;
double s=sqrt(p*(p-a)*(p-b)*(p-c));
std::cout <<"square: " < return 0;
}
- 16.06.2018 22:35
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.