Вопрос по информатике:
Напишите программу,в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор,пока не будет введён ноль) и подсчет суммы и среднего арифмитического введённых положительных чисел.Используйте оператор repeat.
- 06.09.2017 04:26
- Информатика
- remove_red_eye 16020
- thumb_up 5
Ответы и объяснения 1
Program z;
var a,i:integer; max:real;
begin
max:=0;
i:=0;
repeat writeln('Введите число'); read(a);
max:=max+a;
i:=i+1;
until a=0;
writeln('Сумма =',max);
writeln('Средние значение =',max/i);
end.
- 07.09.2017 21:38
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.