Вопрос по информатике:
Напишите программу, которая вводит возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом "год" "года" или "лет". Например "21 год" "22 года" "25 лет"
- 07.10.2017 02:40
- Информатика
- remove_red_eye 12460
- thumb_up 35
Ответы и объяснения 1
Program years;
year:integer;
begin
readln(year);
if(year >0) and(year<=120) then begin
if(year mod 10 =0)or(year mod 10 >=5) then writeln(year, ' лет ')
else if(year mod 10 =1)then writeln(year, ' год ')
else writeln(year, ' года ');
end;
end.
- 09.10.2017 00:34
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.