Вопрос по информатике:
Пожалуйста помогите с решением!!!!
1.Написать программу, которая запрашивает число с клавиатуры и сообщает его квадрат, затем спрашивает пользователя «Нужно продолжить работу?», и пользователь отвечаетда/нет. Программа заканчивает свою работу, если пользователь напечатал слово «нет» на очередной вопрос программы, иначе считает и выдаёт ответ дальше.
2. Дан массив из 10-ти чётных натуральных чисел – от 2 до 20. А) Найдите сумму элементов массива.Б) Найдите минимальный элемент массива.
3. Дан массив из 15 подряд идущих натуральных чисел, начиная с 50.А) Найдите произведение элементов массива.Б) Найдите максимальный элемент массива.
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 16.09.2018 18:48
- Информатика
- remove_red_eye 18920
- thumb_up 46
Ответы и объяснения 1
Второе
var A: array [1..10] of integer;
I,S: integer;
min:=a[1];
beginfor I:=1 to 10 do
begin
a[i]:=random(10);
S:=S+A[I];
write(a[i],' ');
end;
for i:=2 to 10 do
begin
if min>a[i] then
min:=a[i];
end;
writeln;
writeln ('сумма=',S);
writeln ('минимальное=',min);
end.
- 17.09.2018 22:43
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.