Вопрос по информатике:
Население города увеличивается на 3% каждый год. В 1993 году население города составляло 65000. Напишите программу которая выведит на экран предсказываемую численность населения города в каждом году вплоть до 2014
Составьте , пожалуйста , программу.
Паскаль.
- 07.08.2018 04:11
- Информатика
- remove_red_eye 3771
- thumb_up 21
Ответы и объяснения 1
Простая
Program p;
var ch:real;
i:integer;
begin
ch:=65000;
For i:= 1993 to 2013 do
begin
ch:=trunc(ch*1.03);
Writeln('Численность населения в году №',i+1,' равна ',ch);
end;
end.
Для любых данных
Program p;
var year,y1:integer;
ch:real;
i:integer;
begin
Write('Введите начальный год: ');
Readln(year);
Write('Введите конечный год: ');
Readln(y1);
Write('Введите число населения: ');
Readln(ch);
For i:= year to y1-1 do
begin
ch:=trunc(ch*1.03);
Writeln('Численность населения в году №',i+1,' равна ',ch);
end;
end.
- 08.08.2018 09:28
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.