Вопрос по информатике:
Сколько чисел нужно взять в последовательности : 1+2+3+4...N. Чтобы получилось число, больше чем N? При N=252 нужно взять 23 числа
Программа + блок-схема.
- 07.06.2018 23:44
- Информатика
- remove_red_eye 7103
- thumb_up 28
Ответы и объяснения 1
Программа №1:
Var n,i,sum:integer;
Begin
Write('Введите N в последовательности 1+2+3+4...N: '); readln(n);
while(sum
sum:=sum+i;
end;
Writeln('Чтобы получилось число больше ',n,' нужно взять ',i,' числа');
End.
Блок-схема в приложении
Задача №2
Var i:integer;
a1,a:real;
Begin
a:=65000;
for i:=1993 to 2014 do
Begin
Writeln(i,' год - ',a:0:0,' жителей');
a1:=(a/100)*3;
a:=a+a1;
end;
End.
- 08.06.2018 23:42
- thumb_up 16
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.