Вопрос по информатике:
Помогите пожалуйста!!
Единица товара стоит a рублей b копеек. Было куплено n штук этого товара. Сколько рублей и копеек пришлось заплатить за всю покупку? На вход программе подаются три целых числа: 0 a 30 000, 0 b < 100 и 0 n 30 000. Выведите два искомых числа.
- 15.02.2018 20:24
- Информатика
- remove_red_eye 8866
- thumb_up 26
Ответы и объяснения 1
Var a,b,n,a1,b1: integer;
begin write('Введите рубли: ');
readln(a);
write('Введите копейки: ');
readln(b);
write('Введите количество: ');
readln(n);
readln(a,b,n);
if(a>0) and (a0) and (b0) and (n<30000) then begin
b1 := b * n mod 100;
a1 := a * n + b * n div 100;
writeln('Рублей ',a1);
writeln('Копеек ',b1);
end else writeln('Ошибка ввода');
end.
- 16.02.2018 19:02
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.