Вопрос по информатике:
Известны координаты вершин A, B, C треугольника. Напишите программу, вычисляющую площадь этого треугольника.
Пример входных данных:
ха=2
ya=1
xb=6
xc=10
yc=1
Пример выходных данных:
S=16.0
Пожалуйста помогите)
- 14.03.2018 05:37
- Информатика
- remove_red_eye 18102
- thumb_up 24
Ответы и объяснения 2
Program triangle;
var ax,bx,cx,ay,by,cy:integer;
begin
Writeln('Введите координату А по Х');
Readln(ax);
Writeln('Введите координату B по Х');
Readln(bx);
Writeln('Введите координату C по Х');
Readln(cx);
Writeln('Введите координату А по Y');
Readln(ay);
Writeln('Введите координату B по Y');
Readln(by);
Writeln('Введите координату C по Y');
Readln(cy);
Writeln('Площадь треугольника равна ', 0.5*((ax-cx)*(by-cy)-(bx-cx)*(ay-cy)));
end.
- 15.03.2018 09:01
- thumb_up 49
Программа во вложениях) Удачи ) Всё работает) (только я задал координаты всех точек, если нужно по-другому, то в лс)
- 16.03.2018 20:14
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.