Вопрос по информатике:
Написать программу, которая определяет какой элемент максимальный или минимальный первым встречается в одномерном массиве из 10 чисел(паскаль)
- 18.03.2018 07:30
- Информатика
- remove_red_eye 11018
- thumb_up 36
Ответы и объяснения 2
Consr n=10;
var a,i,max,min,k,p:integer;
m:array [1..n] of integer;
begin
for i:=1 to n do
begin
a:=random(21)-10;
m[i]:=a;
write (m[i],' ');
end;
max:=m[1];
min:=m[1];
k:=1;
p:=1;
for i:=1 to n do
begin
if m[i]>max then
begin
max:=m[i];
p:=i;
end;
if m[i]
min:=m[i];
k:=i;
end;
end;
if p>k then writeln ('минимальный раньше')
else writeln ('максимальный раньше');
end.
- 19.03.2018 14:40
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.