Вопрос по информатике:
1.Написать программу, которая вычисляет частное двух чисел. Программа должна проверять правильность введенных пользователем данных и, если они неверные (делитель равен нулю), вы давать сообщение об ошибке. Ниже приведен рекомендуемый вид экрана во время выполнения программы (данные, введенные пользователем, выделены полужирным шрифтом).
Вычисление частного.
Введите в одной строке делимое и делитель,
затем нажмите <enter>.
-> 12 О
Вы ошиблись. Делитель не должен быть равен нулю.
- 13.11.2017 16:43
- Информатика
- remove_red_eye 7469
- thumb_up 17
Ответы и объяснения 1
Program qq;
Var a, b, c:real;
Begin
Writeln('введите два числа');
Readln(a,b);
If b=0 then begin writeln('делитель не должен равняться нулю, введите числа повторно')
readln(a, b);
End
If else begin c:=a/b;
End
Writeln('получившееся число', c)
End.
Может где-нибудь есть косячок, но в основном, все должно получиться, удачи:)
- 14.11.2017 07:41
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.