Вопрос по информатике:
Написать программу обработки двумерного массива: дан массив А 15 строк и 15 столбцов. Заполнить массив случайными числами, найти мах, мин, и сумму элементов всего массива
Нужно в тетраде написать
Нужно написать так,как в паскале
- 08.12.2017 17:06
- Информатика
- remove_red_eye 3889
- thumb_up 40
Ответы и объяснения 1
var a, b, c, d, i, j :integer;
s :array [1..100,1..100] of integer;
begin
b:=63999;
c:=-63999;
for i:=1 to 15 do
begin
writeln;
for j:=1 to 15 do
begin
s[i,j]:=random(127998)-63999;
a:=a+s[i,j];
if s[i,j]>c then c:=s[i,j];
if s[i,j] write (s[i,j],' ');
end;
end;
writeln;
writeln ('Сумма элементов = ', a);
writeln ('Максимальный элемент = ', c);
writeln ('Минимальный элемент = ', b);
end.
- 09.12.2017 16:07
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.