Вопрос по информатике:
Напишите программу, которая в последовательности целых чисел определяет среднее арифметическое нечётных чисел. Программа получает на вход целые положительные числа. Количества введенных чисел не известно.
- 08.07.2018 03:49
- Информатика
- remove_red_eye 19470
- thumb_up 42
Ответы и объяснения 1
uses crt;
var i,sum,k: integer;
begin
sum:=0;
k:=0;
writeln('Вводите числа. 0 - конец последовательности');
repeat
read(i);
if i mod 2=1 then begin
sum:=sum+i;
inc(k);
end;
until i=0;
writeln;
writeln('Среднее арифметическое нечетных чисел: ',sum/k:5:3);
end.
- 09.07.2018 17:17
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.